Can't expand filesystem

Post Reply
jam08033
Posts: 3
Joined: Sat Feb 29, 2020 5:45 pm

Can't expand filesystem

Post by jam08033 » Thu Mar 05, 2020 5:21 pm

I've installed the Ver 5 image on a 32 Gig SD card, but I'm not able to expand the file system. I've tried to it from raspi-config (Advanced->Expand Filesystem) and by using raspi-config --expand-rootfs, but I always get the same:

$ lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
mmcblk0 179:0 0 28.9G 0 disk
├─mmcblk0p1 179:1 0 256M 0 part /boot
└─mmcblk0p2 179:2 0 28.7G 0 part /

$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 4.1G 3.9G 16M 100% /
devtmpfs 841M 0 841M 0% /dev
tmpfs 970M 0 970M 0% /dev/shm
tmpfs 970M 8.5M 962M 1% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 970M 0 970M 0% /sys/fs/cgroup
/dev/mmcblk0p1 253M 53M 200M 21% /boot
tmpfs 194M 4.0K 194M 1% /run/user/1000


I'm still a raspy newbie, so sorry if I'm not grasping the difference between partitions/filesystems/devices. I'd rather not go through the hassle of resizing using parted, so I hope I'm missing something obvious.

The board is running for now, and I love it, but with no space left, it's only a matter of time before it comes crashing down around me! Thanks so much.

jam08033
Posts: 3
Joined: Sat Feb 29, 2020 5:45 pm

Re: Can't expand filesystem

Post by jam08033 » Mon Mar 09, 2020 4:53 pm

OK, I sorta have an answer to my own question. After other tries at solutions (updating raps-config and running file expansion again, shutting down instead of "just" rebooting, etc), all with no resolution, I ran SD Card Copier from the RP, and copied to another 32G card. It worked! The /root filesystem expanded to the entire partition, and I'm ready to go. I still don't know why the raps-config didn't work (I was going to dissect the script to run the components separately), but all's well that ends well.

Bertus Kruger
Site Admin
Posts: 1594
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: Can't expand filesystem

Post by Bertus Kruger » Sun Mar 15, 2020 7:33 pm

That is unusual... :?

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests