confused about external driver and wiring

ljungberg
Posts: 26
Joined: Tue May 09, 2017 11:12 am

confused about external driver and wiring

Post by ljungberg » Mon Jan 27, 2020 1:30 am

hi

i just cant get my head around the wiring the external drivers.
i have sertched a lot before posting and cant find anything about it

bord 2,60(C)

1. i made a pic of what i think is correct, am i?
https://ibb.co/K7bxtn7

2. the ? on my pic above what determines the voltage and were dose it come from?
is it an power input?

3. i plan to use a M542T driver(s), it is bought as a kit 4 drivers, 4 motors and 36VDC power supply, but as seen in the description the motors are/needs a Voltage of: 4.2V.
after reading the driver manual i cant find any mention about voltage regulation or setting voltage.
i can only find current. as it is sold as a kit one can assume its compatible.
the documentation says other vise or lack off.

(it was old as a 4 axis kit before)
https://www.omc-stepperonline.com/sale. ... order=DESC

4. the rst,Resume, abort and hold has also a gnd and 5v.
are they triggerd with 5v or gnd?

ckoppenaal
Posts: 24
Joined: Fri May 18, 2018 1:11 pm

Re: confused about external driver and wiring

Post by ckoppenaal » Mon Jan 27, 2020 2:54 pm

This is how I have mine wired up, I am not an expert but it works for me.

Hat / Driver
Step / PUL-
Dir / DIR-

For the PUL+ and the DIR+ on the driver I have an external 5volt power supply providing 5 volts to those inputs. I have nothing connected to the ENA on the driver because by default they are enabled if nothing is connected. The power supply you have should be fine, connect it to the DC- and DC+ on the driver, the power supply should not be connected to the hat. As I stated I am not an expert and my set-up is different from yours but I believe this should work for you also.

ljungberg
Posts: 26
Joined: Tue May 09, 2017 11:12 am

Re: confused about external driver and wiring

Post by ljungberg » Mon Jan 27, 2020 3:26 pm

what driver do you have?

ckoppenaal
Posts: 24
Joined: Fri May 18, 2018 1:11 pm

Re: confused about external driver and wiring

Post by ckoppenaal » Mon Jan 27, 2020 3:40 pm

iHSS57-36-20 JMC Nema 23 2Nm DC36V Integrated Closed Loop Stepper motor with driver

The wiring is the same




https://www.amazon.com/UCONTRO-iHSS57-3 ... B074DTLDXC

ljungberg
Posts: 26
Joined: Tue May 09, 2017 11:12 am

Re: confused about external driver and wiring

Post by ljungberg » Mon Jan 27, 2020 4:51 pm

If 5v is needed i would be able to use the rpi 5v or?

ckoppenaal
Posts: 24
Joined: Fri May 18, 2018 1:11 pm

Re: confused about external driver and wiring

Post by ckoppenaal » Mon Jan 27, 2020 5:06 pm

You can use any 5volt source, but you must give the PUL+ and DIR+ a 5volt signal. I am not sure if the Enable pin on the hat is supposed to supply the 5volts, but I could not get that to work. Thats why I used a 5volt power supply.

Bertus Kruger
Site Admin
Posts: 1678
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: confused about external driver and wiring

Post by Bertus Kruger » Mon Jan 27, 2020 6:45 pm

ckoppenaal wrote:
Mon Jan 27, 2020 5:06 pm
You can use any 5volt source, but you must give the PUL+ and DIR+ a 5volt signal. I am not sure if the Enable pin on the hat is supposed to supply the 5volts, but I could not get that to work. Thats why I used a 5volt power supply.
I would not use the enable pin as its inverted and might not supply enough current.

There is a 5V pin under the grove connector that will supply 5V from the USB feeding the RPI.

PUL+ and DIR+ is correct and running at 5V

ljungberg
Posts: 26
Joined: Tue May 09, 2017 11:12 am

Re: confused about external driver and wiring

Post by ljungberg » Mon Jan 27, 2020 10:00 pm

ok i just bought a external 5v transformer so PUL+ and DIR+ will get 5v dc constant.
so just to be 100% sure PUL+ and DIR+ shall have constant 5v dc?

ckoppenaal
Posts: 24
Joined: Fri May 18, 2018 1:11 pm

Re: confused about external driver and wiring

Post by ckoppenaal » Tue Jan 28, 2020 1:05 pm

That is correct, just like it shows on the drive. V+ on the power supply will go to PUL+ and DIR+.

ljungberg
Posts: 26
Joined: Tue May 09, 2017 11:12 am

Re: confused about external driver and wiring

Post by ljungberg » Sun Feb 02, 2020 11:56 pm

ckoppenaal wrote:
Mon Jan 27, 2020 2:54 pm
This is how I have mine wired up, I am not an expert but it works for me.

Hat / Driver
Step / PUL-
Dir / DIR-

For the PUL+ and the DIR+ on the driver I have an external 5volt power supply providing 5 volts to those inputs. I have nothing connected to the ENA on the driver because by default they are enabled if nothing is connected. The power supply you have should be fine, connect it to the DC- and DC+ on the driver, the power supply should not be connected to the hat. As I stated I am not an expert and my set-up is different from yours but I believe this should work for you also.
Well as I did know you cant have a external power supply.
Just trying it out of boredom and it did not work.
You need to take the 5v from the rpi or you loses your reference and never know the voltage.
Could you reverse the step and dirr so it uses positive instead of negative?

I get some weird motor movement now.
Bcnc button: motor movement
Z+ : x- and A-
Z- : z+
Y-: A-
Y+:x-
X-:x-
X+: A+

You see x- is moving on 3 axis so does A.
Y dose never move.

My reward of 50 $ to the person who get my cnc working isn't claimed yet. See my other thread of serial port problem for requirements.

Post Reply

Who is online

Users browsing this forum: Google Adsense [Bot] and 1 guest