Finally done

Post Reply
erniehatt
Posts: 256
Joined: Thu Nov 03, 2016 8:16 am

Finally done

Post by erniehatt » Sun Oct 06, 2019 4:09 am

Hi, a couple of years ago, I built a CNC, although it worked OK, I thought it was to bulky, also the motors seemed th be struggling under the Weight.
So I decided to rebuild it, and here it is.
One more thing to make, and thats a spoil board, and then to level everthing up, apart from that everything is working, a bit noisy but I am led to believe that's pretty normal.
I will most likely shift the screen to the top of the gantry.
CNC1.jpg
CNC1.jpg (329.15 KiB) Viewed 443 times
Attachments
CNC2.jpg
CNC2.jpg (476.89 KiB) Viewed 443 times

Bertus Kruger
Site Admin
Posts: 1503
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: Finally done

Post by Bertus Kruger » Mon Oct 07, 2019 6:31 pm

erniehatt wrote:
Sun Oct 06, 2019 4:09 am
...a bit noisy but I am led to believe that's pretty normal.
don't forget dusty as well... :D

Looking good!!!

erniehatt
Posts: 256
Joined: Thu Nov 03, 2016 8:16 am

Re: Finally done

Post by erniehatt » Mon Oct 07, 2019 9:19 pm

don't forget dusty as well... :D
Thanks Bertus,
I would say more like very messy :!:

erniehatt
Posts: 256
Joined: Thu Nov 03, 2016 8:16 am

Re: Finally done

Post by erniehatt » Sat Oct 12, 2019 1:35 am

I have the spoil board built and am writing Gcode to level it, and have notice some anomalies.
1) the axis's are running in the wrong direction, OK this is easily fixed, but I wrote the Gcode to suit this, but I notice that BCNC corrected this misdirection, is that normal. So I corrected the code to suit BCNC, here's a copy, do you see any problems.
2) The file is just not running correctly, The X axis will suddenly stop, and the Y will continue running through then the X will start again.
Tried it in both BCNC and UGS with different results.
EDIT. A bit more info, In BCNC it starts OK then stops part way through.
In UGS it starts but gives me a message,(IOExtention while sending command null) I am hoping someone can give me a clue here.
Perhaps it's a setting in GRBL.
Edit2. IN BCNC it stops at the same spot every time, It moves to the G1 Y140 and stops.
EDIT3. It has to be something to do with this Gcode as I have tried others and they work OK.
Thanks

*Code to level base plate*
G1 X0 Y0 Z0 F250
G1 Z0.25
G1 X-242
G1 Y-28
G1 X0
G1 Y-56
G1 X-242
G1 Y-84
G1 X0
G1 Y-112
G1 X-242
G1 Y-140
G1 X0
G1 Y-168
G1 X-242
G1 Y-196
G1 X0
G1 Y-224
G1 X-242
G1 Y-252
G1 X0
G1 Y-280
G1 X-242
G1 Y-308
G1 X0
G1 Y-336
G1 X-242
G1 Y-364
G1 X0
G1 Y-372
G1 X-242
G1 Z-10
G1 Y0
G1 X0

erniehatt
Posts: 256
Joined: Thu Nov 03, 2016 8:16 am

Re: Finally done

Post by erniehatt » Tue Oct 15, 2019 11:59 pm

finally found the problem, it did not like the gcode heading deleted it and all's fine again :lol:

erniehatt
Posts: 256
Joined: Thu Nov 03, 2016 8:16 am

Re: Finally done

Post by erniehatt » Mon Oct 28, 2019 12:14 am

the spoil board is finished.
I made it out of 6mm acrylic, it is fully waterproof, i want to try some aluminum cutting, so the next thing will be to add a water spray system.
My first project will be to try a small PCB, I will post the results.
CNC.jpg
CNC.jpg (373.52 KiB) Viewed 136 times

ckoppenaal
Posts: 13
Joined: Fri May 18, 2018 1:11 pm

Re: Finally done

Post by ckoppenaal » Tue Oct 29, 2019 1:34 pm

looks good

erniehatt
Posts: 256
Joined: Thu Nov 03, 2016 8:16 am

Re: Finally done

Post by erniehatt » Wed Oct 30, 2019 9:05 am

Thanks Pal, just hope it works as well as it looks, have done a dry run on it and all seems to function as it should, probably will have to do some tweaking.

erniehatt
Posts: 256
Joined: Thu Nov 03, 2016 8:16 am

Re: Finally done

Post by erniehatt » Fri Nov 01, 2019 6:18 am

Well the first effort, a small circuit board, did not turn out to well, it went through all the motions, but not a usable result.
Must go back and recheck all settings.
The spoil board failed too, the acrylic did not like silicon.
So I am building another out of plywood, see how that one goes.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest