Issues with Rpi-CNC + Jetson Nano or FTDI

Post Reply
nest
Posts: 1
Joined: Sat Sep 07, 2019 9:42 am

Issues with Rpi-CNC + Jetson Nano or FTDI

Post by nest » Sat Sep 07, 2019 9:57 am

Hello,
I recently received 2 Protoneers board and can't wait to start using them :D My application does not involve a Raspberry Pi but a Jetson Nano (same 40 pins header). I'm running into a serial communication issue I can't understand, maybe someone here we'll be able to help me. Below are the steps I followed:

1. Test of the Jetson Nano UART: PC <> Sparkfun FTDI 3.3V <> Jetson Nano (JN) 40 pins header. I can successfully send and receive data between my PC and the JN.

2. Connection of the Protoneer to JN trough the 40 pins header. Boot-up and starts minicom with correct UART settings (115200 - 8N1). Commands from JN to Grbl are OK but feedback from Grbl to JN is corrupted. For example "$G" command outputs:

Code: Select all

[GC:G0\80T\D2T\8A:\E5M5 M9 \AC\98\AD5)\FF
instead of something like

Code: Select all

[GC:G0 G54 G17 G21 G90 G94 M0 M5 M9 T0 S0.0 F500.0]
. Needless to say bCNC can't connect to Grbl either as communication seems corrupted.

3. If I now try to use the FTDI of step 1 to have Jetson Nano <> Sparkfun FTDI 3.3V <> Rpi-CNC, data from Rpi-CNC is now correctly displayed (boot-up message) but I can't send and commands.

What am I missing? Thank you in advance :)

Bertus Kruger
Site Admin
Posts: 1475
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: Issues with Rpi-CNC + Jetson Nano or FTDI

Post by Bertus Kruger » Wed Sep 11, 2019 7:29 pm

Few things to consider. The hat used 3.3V and 5V.

It has level shifters and UART is all done via 3.3V. On the GRBL side things are converted to 5V

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest