I2C communication on the shield (not the Grove connection)

Post Reply
vitsensei
Posts: 6
Joined: Wed Dec 19, 2018 10:59 pm

I2C communication on the shield (not the Grove connection)

Post by vitsensei » Fri Jan 11, 2019 12:33 pm

I burn the bootloader of the board and upload my Arduino sketch onto it.

So currently I'm connecting 3.3V, ground, A4 and probe pin to my IMU sensor which uses I2C communication.
For some reason, I'm not detecting the sensor (but if I use the same code upload to a Nano then it works fine). Any insight?

I don't think uploading the code is necessary since, with I2C, you need the same hardware as I have for the code to work anyways. But if you can guess what is the problem or is it even possible to have I2C communication on the Protoneer Shield at all?

I'm also using a multiplexer to control multiple IMU sensors at the same time if that makes a difference at all.

Thanks.

Bertus Kruger
Site Admin
Posts: 1319
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: I2C communication on the shield (not the Grove connection)

Post by Bertus Kruger » Sun Jan 13, 2019 6:34 pm

vitsensei wrote:
Fri Jan 11, 2019 12:33 pm
So currently I'm connecting 3.3V, ground, A4 and probe pin to my IMU sensor which uses I2C communication.
For some reason, I'm not detecting the sensor (but if I use the same code upload to a Nano then it works fine). Any insight?
The MCU is running at 5V. You will need to connect A5 as well because that is the clock pin for I2C. Then there is also Pull-up resistor that are needed 10K on both I2C lines...

vitsensei
Posts: 6
Joined: Wed Dec 19, 2018 10:59 pm

Re: I2C communication on the shield (not the Grove connection)

Post by vitsensei » Sun Jan 13, 2019 9:59 pm

Bertus Kruger wrote:
Sun Jan 13, 2019 6:34 pm
The MCU is running at 5V. You will need to connect A5 as well because that is the clock pin for I2C. Then there is also Pull-up resistor that are needed 10K on both I2C lines...
Aren't A5 probe pin? That's the GRBL standard, right?

Bertus Kruger
Site Admin
Posts: 1319
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: I2C communication on the shield (not the Grove connection)

Post by Bertus Kruger » Mon Jan 14, 2019 6:52 pm

Yes. A5 is probe...

vitsensei
Posts: 6
Joined: Wed Dec 19, 2018 10:59 pm

Re: I2C communication on the shield (not the Grove connection)

Post by vitsensei » Wed Jan 16, 2019 5:56 am

Quick update. Turn out there's a capacitor connected to probe. So in order for me to use it for digital signals, I have to remove the capacitor.

berin
Posts: 26
Joined: Sun Sep 02, 2018 4:32 pm

Re: I2C communication on the shield (not the Grove connection)

Post by berin » Thu Jan 17, 2019 11:46 pm

GROVE 2MM 4PIN CONN 10PACK) 1597-1082-ND 1597-1083-ND one is the vertical and the other is the 90 degree version. These are from digikey. these are 100% compatible with the grove connector for the I2C on the RPI hat. And they are sold from digikey in packs of 10 for $1.5 USD
JUST REMEMBER these are 2mm not 2.5mm like standard PERF board. they will fit standard perf board but you have to bend the pins a little.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest