Laser not firing in laserweb

StuartB
Posts: 74
Joined: Wed Jun 07, 2017 2:25 pm

Re: Laser not firing in laserweb

Post by StuartB » Sat Dec 30, 2017 6:34 pm

gmoney484 wrote: ↑
Sat Dec 30, 2017 8:22 am

StuartB wrote: ↑
Fri Dec 29, 2017 1:42 pm
Try LaserGRBL. It's completely free and generates the GCode depending on the settings you choose.
Greyscale, Solid or Outline Burning.
http://lasergrbl.com/en

Great software but only works with Windows. You get my vote if you can get it going on a Pi :)

True I used it to generate gcode which I loaded into both BCNC and UGS and it did not work.

Oh ok, I just thought as you were using GRBL 1.1 it would be ok.

erniehatt
Posts: 234
Joined: Thu Nov 03, 2016 8:16 am

Re: Laser not firing in laserweb

Post by erniehatt » Sat Dec 30, 2017 8:52 pm

I could not understand why it did not work, the g-code looked OK, I have used other files in windows that had no problems.
Maybe I got some settings wrong, I take a closer look at it.
I will attach a link for one that does work.
https://drive.google.com/folderview?id= ... sp=sharing

Jasonpgr
Posts: 25
Joined: Sat May 13, 2017 6:03 am

Re: Laser not firing in laserweb

Post by Jasonpgr » Wed Jan 03, 2018 3:03 am

Lasergrbl is amazing! I threw an image in, saved the gcode and I'm streaming it to the cutter via the laserweb3 server on the rpi. Images look great. pwm looks great. And the software was free and super easy to use. So glad I got bored and decided to make a laser cutter!

erniehatt
Posts: 234
Joined: Thu Nov 03, 2016 8:16 am

Re: Laser not firing in laserweb

Post by erniehatt » Wed Jan 03, 2018 4:20 am

Good news,
I found why it did not work on mine, it had developed a problem with the X axis.

gmoney484
Posts: 135
Joined: Wed Nov 09, 2016 8:52 pm

Re: Laser not firing in laserweb

Post by gmoney484 » Wed Jan 03, 2018 6:16 am

Jasonpgr wrote:
Wed Jan 03, 2018 3:03 am
Lasergrbl is amazing! I threw an image in, saved the gcode and I'm streaming it to the cutter via the laserweb3 server on the rpi. Images look great. pwm looks great. And the software was free and super easy to use. So glad I got bored and decided to make a laser cutter!
You got my vote :)
Gavin Milne
HoD Science
Dilworth School

yisabell
Posts: 15
Joined: Tue Mar 20, 2018 6:23 pm

Re: Laser not firing in laserweb

Post by yisabell » Wed May 16, 2018 11:37 pm

Jasonpgr wrote:
Fri Dec 29, 2017 5:12 am
Now I'm even more confused....... I entered in your sample Gcode manually and the laser fired right up. And now I've managed to export a couple different files out of inkscape that all seem to to be working fine. No idea what I did differently, or what changed, but all seems to be well now. One thing I did change was the PWM in inkscape from 255 up to 1000 since thats the max rpm in GRBl and as I suspected my laser got MUCH brighter when I did that. That also confirms whether or now I can dim my laser up and down for making cool graphics and raster images, and it seems like I will be able to. So all is well now I suppose.
What was the sample code that you used to unlock this...I have the very same problem, however I am testing with minicom & bCNC and nothing will generate any voltage on the PWM terminals. I have been using an LED with a 10K resistor. I verify LED working at 5V but to no avail I can't get it to fire.

Any suggestions?

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests