Pi 4B no serial

Post Reply
WZ9V
Posts: 1
Joined: Wed Aug 21, 2019 5:27 pm

Pi 4B no serial

Post by WZ9V » Wed Aug 21, 2019 5:36 pm

I installed the hat on a pi 4B and booted up with the latest Raspbian desktop OS with SSH enabled.

Using SSH, I ran raspi-config and turned off the serial console and enabled serial. No GRBL status with minicom (ttyAMA0)

I tried the conmmands for the pi 3B+ from Github and still no status in minicom.

Any other tricks to try?

I want to get serial sorted out with minicom before moving on to the other software.

Bertus Kruger
Site Admin
Posts: 1475
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: Pi 4B no serial

Post by Bertus Kruger » Sun Sep 01, 2019 7:29 pm

WZ9V wrote:
Wed Aug 21, 2019 5:36 pm
I installed the hat on a pi 4B and booted up with the latest Raspbian desktop OS with SSH enabled.

Using SSH, I ran raspi-config and turned off the serial console and enabled serial. No GRBL status with minicom (ttyAMA0)

I tried the conmmands for the pi 3B+ from Github and still no status in minicom.

Any other tricks to try?

I want to get serial sorted out with minicom before moving on to the other software.
This is the main script that should configure the serial...
https://github.com/Protoneer/RPI-CNC-Co ... -Config.sh

I am working on an update RPi 4 image that should do this automatically.

wimdb
Posts: 2
Joined: Fri Aug 09, 2019 1:32 pm

Re: Pi 4B no serial

Post by wimdb » Tue Sep 10, 2019 8:50 am

Pi 4 uses a different serial port on the pins for serial communication with the CNC-hat: ttyS0 instead of ttyAMA0.
Try starting minicom this way: minicom -D /dev/ttyS0
Next the command ctrl-X should give you the grbl-message: Grbl 1.1f [‘$’ for help]

I use bCNC and faced one other issue with ttyS0 It is not recognized automatically by bCNC. You have to manually change the port parameter in the .bCNC config file: port = /dev/ttyS0

Good luck.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests