Spindle Motor 'Floating' on startup

Question/Answers related to this version of the board.
Post Reply
Posts: 6
Joined: Sat Mar 17, 2018 5:04 am
Location: United Kingdom

Spindle Motor 'Floating' on startup

Post by willower » Mon Apr 09, 2018 8:47 pm

I have noticed that when starting my software (grblPanel v1., it seems that the spindle motor, which I run through a relay, is struggling to decide whether or not to have the spindle motor running (switched on) or not (switched off). Invariably, it eventually decides to have it running, but it is by no means certain always that way - probably 50/50 to be honest. This makes me think that it should be starting in the off state - but can't quite make up its mind!

Is there somewhere in the config h file that sets this parameter for startup? I am carrying out a homing operation immediately after startup and following this up with an M04 command from the command line to stop the motor. After this, all works fine.

I have tried to create a startup block to issue the M04 command at startup, but it seems that the $N=M04S0 does not work in grblPanel. In fact I can't seem to get any $N commands to do anything, they don't even show any feedback? Perplexed by this....

My only thoughts are that I should install a switch in the system as an override on the motor circuit. Has anyone else had this problem?

Machine = 3018 Engraving machine
Software = Vectric Cut2D
Machine Control = grblPanel
Arduino R3 with Protoneer v3.51 Shield and grbl v1.1f


Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests