[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 580: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 636: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4511: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3257)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4511: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3257)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4511: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3257)
Protoneer Product Forum • CNC board not communicating on startup
Page 1 of 1

CNC board not communicating on startup

Posted: Thu Jan 27, 2022 4:15 pm
by shipmack
I posted this on in the v2.58 board 12/17 and didn't get a reply.

I have the Raspberry Pi CNC board on a RPI 4. I worked as advertised and still does. My problem is with restarting the machine.

Every time I restart, my status always starts up as Not Connected. When I click on the banner, it tells me GRBL is connected and communicating.
Capture.JPG
Capture.JPG (38.3 KiB) Viewed 580 times
I have to exit the program and run the firmware updater to get communications working again. However, it is not a clean process. After restarting, it is in ALARM that I clear with the reset button on the board. I then have to close communication and then open it again to then get the machine running again.

I have used the RPI3/4 script.

What do I need to do to get the board to start up without running the firmware updater first?