raspberry pi hat and bCNC locks up

Post Reply
crchisholm
Posts: 4
Joined: Thu Mar 15, 2018 8:18 pm

raspberry pi hat and bCNC locks up

Post by crchisholm » Sat Apr 21, 2018 7:14 pm

I setup the Protoneer Raspberry Pi Hat using the SD card I ordered at the same time. I got everything running ok on a Raspberry Pi 3, but when I tried to run bCNC, the software locked up (became unresponsive). Couldn't even close the bCNC window and had to reboot. All the normal bundled RP stuff seemed to work ok. I then tried to run UGS (which I know nothing about) and it said it connected ok, but when I tried to move an axis, I got a message saying that GRBL was not done loading (and apparently never finished). I tried using the SD card on another pi (B 2+) and got all the same results (or lack there of). I thought the SD card might be the problem so I downloaded the image from the protoneer site and installed it on a fresh SD card. Same results.

I was going to run the serial port test, but apparently I have to completely disassemble the pi hat and pi to get to GPIO14 and GPIO15 to short them, it didn't seem like a good test since I was getting the same results on an entirely different RP.

Any guidance?
Charlie

Bertus Kruger
Site Admin
Posts: 1594
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: raspberry pi hat and bCNC locks up

Post by Bertus Kruger » Mon Apr 23, 2018 12:46 am

Few issues... We recently updated the Image to V4.1. This fixed issues with the latest Rpi 3b+.

Did you run the RPI3 config script that is on the desktop? that reconfigures the RPi 3's serial to work
correctly.

I would then run the minicom shortcut and when the console window opens press ? a few times. This will
echo the GRBL state back.

The serial test is just to check that the RPi serial side is setup correctly.

crchisholm
Posts: 4
Joined: Thu Mar 15, 2018 8:18 pm

Re: raspberry pi hat and bCNC locks up

Post by crchisholm » Mon Apr 23, 2018 10:53 pm

I will give this a go tomorrow. I am not at the pi right now so I can't answer your question. When did you upload the v4.1 image. I think the one I downloaded was last Friday +/- a day or two.

Bertus Kruger
Site Admin
Posts: 1594
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: raspberry pi hat and bCNC locks up

Post by Bertus Kruger » Tue Apr 24, 2018 1:33 am

crchisholm wrote:
Mon Apr 23, 2018 10:53 pm
I will give this a go tomorrow. I am not at the pi right now so I can't answer your question. When did you upload the v4.1 image. I think the one I downloaded was last Friday +/- a day or two.
Last update was on the 11th https://wiki.protoneer.co.nz/Raspberry_ ... Card_Image

crchisholm
Posts: 4
Joined: Thu Mar 15, 2018 8:18 pm

Re: raspberry pi hat and bCNC locks up

Post by crchisholm » Tue Apr 24, 2018 3:07 pm

Yep. Seems that the pi3 script you provide worked. It no longer locks up, so it had to be something to do with the port configuration.
Thank you very much for the support.

Charlie

Bertus Kruger
Site Admin
Posts: 1594
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: raspberry pi hat and bCNC locks up

Post by Bertus Kruger » Sun Apr 29, 2018 7:43 pm

crchisholm wrote:
Tue Apr 24, 2018 3:07 pm
Yep. Seems that the pi3 script you provide worked. It no longer locks up, so it had to be something to do with the port configuration.
Thank you very much for the support.

Charlie
Good stuff.... ;)

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 2 guests