CNC board not communicating on startup

Post Reply [phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
shipmack
Posts: 6
Joined: Mon Mar 08, 2021 10:27 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

CNC board not communicating on startup

Post by shipmack » Thu Jan 27, 2022 4:15 pm

I posted this on in the v2.58 board 12/17 and didn't get a reply.

I have the Raspberry Pi CNC board on a RPI 4. I worked as advertised and still does. My problem is with restarting the machine.

Every time I restart, my status always starts up as Not Connected. When I click on the banner, it tells me GRBL is connected and communicating.
Capture.JPG
Capture.JPG (38.3 KiB) Viewed 372 times
I have to exit the program and run the firmware updater to get communications working again. However, it is not a clean process. After restarting, it is in ALARM that I clear with the reset button on the board. I then have to close communication and then open it again to then get the machine running again.

I have used the RPI3/4 script.

What do I need to do to get the board to start up without running the firmware updater first?

Post Reply [phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Who is online

Users browsing this forum: No registered users and 2 guests