versin 2.58

proton258
Posts: 9
Joined: Tue Mar 19, 2019 7:50 pm

versin 2.58

Post by proton258 » Tue Mar 19, 2019 8:15 pm

Hi
Bought a version 2.58 board
Bought raspberry pi 2 model B
Bought 3 nema 23 stepper motors
Bought 3 m542t stepper drivers
Bought 1 power supply for stepper motors

Wired everything together after watching numerous Youtube videos
Checked the pairs of wires on the stepper motor to verify i had the correct wires for A and B
When no power to the stepper motors the spindles will spin...when power to the stepper motors the spindle will not turn
Loaded the software to the raspberry pi from protoneer and the raspberry pi and the board are up and running

BCNC starts and says i am connected to the serial port of the raspberry pi and protoneer board, the protoneer board leds for rx and tx flash when i initiate commands in BCNC
The m542t stepper drivers led is green and the other wiring to the other components seems to be correctly wired....but when i initiate command via BCNC nothing happens...

To get my solution working, do i require the external driver board(s) for the cnc hat 2.58...if so, how can i obtain this board.
Or, Is there any other wiring solution i define to get my solution working...

Hope you can help me diagnosing what my issue is....

Bertus Kruger
Site Admin
Posts: 1649
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: versin 2.58

Post by Bertus Kruger » Tue Mar 19, 2019 8:55 pm

Please post a photo of how you wired it up...

proton258
Posts: 9
Joined: Tue Mar 19, 2019 7:50 pm

Re: versin 2.58

Post by proton258 » Tue Mar 19, 2019 11:43 pm

Hi Bertus

tried to attach photos but get error message that the file is to big. what is the correct size photo i can attach

thanks

proton258
Posts: 9
Joined: Tue Mar 19, 2019 7:50 pm

Re: versin 2.58

Post by proton258 » Tue Mar 19, 2019 11:53 pm

Hi Bertus

see attached photos...if you want to see anything specific, tell me and i will take new pictures

thanks for the help
Attachments
885C0023-D92C-4D58-9F83-8F84B35EF262.jpeg
885C0023-D92C-4D58-9F83-8F84B35EF262.jpeg (279.87 KiB) Viewed 1192 times
FA39659C-1CE1-4699-AA36-E08C082CDEF1.jpeg
FA39659C-1CE1-4699-AA36-E08C082CDEF1.jpeg (325.64 KiB) Viewed 1192 times
72197AA2-3B19-45AF-ACD9-D991E5751CC3.jpeg
72197AA2-3B19-45AF-ACD9-D991E5751CC3.jpeg (253.65 KiB) Viewed 1192 times

proton258
Posts: 9
Joined: Tue Mar 19, 2019 7:50 pm

Re: versin 2.58

Post by proton258 » Wed Mar 20, 2019 11:35 pm

posted pictures, what do you think i have done wrong. do i need the external driver boards?

Bertus Kruger
Site Admin
Posts: 1649
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: versin 2.58

Post by Bertus Kruger » Sun Mar 24, 2019 6:15 pm

proton258 wrote:
Wed Mar 20, 2019 11:35 pm
posted pictures, what do you think i have done wrong. do i need the external driver boards?
You definitely need the external drive boards with your setup. The external driver boards rewires the signal pins to the green connectors.

In your current setup they signal pins are all disconnected.

proton258
Posts: 9
Joined: Tue Mar 19, 2019 7:50 pm

Re: versin 2.58

Post by proton258 » Tue Mar 26, 2019 10:03 pm

Hi

I have installed the a49888 boards to the 2.58 protoneer board and i have wired the board to the m542t in the following way...is this correct ???

I have wired the 4 pin green connecter on the 2.58 board in the following way
purple wire = ground and connects to dir- and pul- on m542t
blue wire = enable + on m542t
brown wire = pul+ on m542t
yellow/green wire =dir+ on m542t

ena- not connected on m542t

see picture below

I still cannot get the nema 23 motor to do anything...help please
Attachments
EA881574-DD71-49E1-8AC8-02CD9E3912CC.jpeg
EA881574-DD71-49E1-8AC8-02CD9E3912CC.jpeg (292.88 KiB) Viewed 1159 times

proton258
Posts: 9
Joined: Tue Mar 19, 2019 7:50 pm

Re: versin 2.58

Post by proton258 » Tue Mar 26, 2019 10:19 pm

hi

when you install the a49888 boards on the 2.58 board, do you need to install the jumper pins also, see atteached image
Attachments
9A498AA8-0253-49C3-88F5-9CCFFAA43ED0.jpeg
9A498AA8-0253-49C3-88F5-9CCFFAA43ED0.jpeg (262.23 KiB) Viewed 1156 times

Bertus Kruger
Site Admin
Posts: 1649
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: versin 2.58

Post by Bertus Kruger » Thu Mar 28, 2019 6:31 pm

proton258 wrote:
Tue Mar 26, 2019 10:03 pm
Hi

I have installed the a49888 boards to the 2.58 protoneer board and i have wired the board to the m542t in the following way...is this correct ???

I have wired the 4 pin green connecter on the 2.58 board in the following way
purple wire = ground and connects to dir- and pul- on m542t
blue wire = enable + on m542t
brown wire = pul+ on m542t
yellow/green wire =dir+ on m542t

ena- not connected on m542t

see picture below

I still cannot get the nema 23 motor to do anything...help please
THIS WILL BREAK YOUR M542T DRIVERS!!!!

What you are doing here taking the wires that should be used to driver a stepper motor and connecting them to the inputs of another stepper driver.
(Taking high voltage and connecting it to low voltage pins = lots of smoke)

Bertus Kruger
Site Admin
Posts: 1649
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: versin 2.58

Post by Bertus Kruger » Thu Mar 28, 2019 6:37 pm


Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests