installing UGS on PI3

erniehatt
Posts: 292
Joined: Thu Nov 03, 2016 8:16 am

Re: installing UGS on PI3

Post by erniehatt » Tue Jan 10, 2017 9:05 pm

Hi Bertus,
Yes read through that post, and a lot of things, are similar to what I am experiencing,, but nothing seems to change anything.
Yes unplugging the power can at times do wonders, I have used on many occasions to fix PC problems, didn't do much for the PI though.
As you may by now realise I have purchased another board, and hope it makes a difference, if not then I have a spare, but I hope it fixes things, then I have not wasted my Cash.
Is the new software available yet, I would like to use that when I connect it all together again.
It still puzzles me as to why it is working nicely one instance and not the next

rmasci
Posts: 21
Joined: Sat Oct 22, 2016 2:23 pm

Re: installing UGS on PI3

Post by rmasci » Sat Jan 14, 2017 2:29 am

That URL works for me off my Raspberry PI:

Code: Select all

pi@xcarve:~ $ wget http://bit.ly/1M6z2ys -O ugs.zip
converted 'http://bit.ly/1M6z2ys' (ISO-8859-1) -> 'http://bit.ly/1M6z2ys' (UTF-8)
--2017-01-13 21:21:09--  http://bit.ly/1M6z2ys
Resolving bit.ly (bit.ly)... 67.199.248.10, 67.199.248.11
Connecting to bit.ly (bit.ly)|67.199.248.10|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://github.com/winder/builds/raw/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip [following]
converted 'https://github.com/winder/builds/raw/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip' (ISO-8859-1) -> 'https://github.com/winder/builds/raw/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip' (UTF-8)
--2017-01-13 21:21:10--  https://github.com/winder/builds/raw/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip
Resolving github.com (github.com)... 192.30.253.113, 192.30.253.112
Connecting to github.com (github.com)|192.30.253.113|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://raw.githubusercontent.com/winder/builds/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip [following]
converted 'https://raw.githubusercontent.com/winder/builds/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip' (ISO-8859-1) -> 'https://raw.githubusercontent.com/winder/builds/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip' (UTF-8)
--2017-01-13 21:21:10--  https://raw.githubusercontent.com/winder/builds/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.128.133, 151.101.64.133, 151.101.0.133, ...
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.128.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10078481 (9.6M) [application/octet-stream]
Saving to: 'ugs.zip'

ugs.zip                                 100%[=================================================================================>]   9.61M  3.11MB/s   in 3.1s

2017-01-13 21:21:14 (3.11 MB/s) - 'ugs.zip' saved [10078481/10078481]

pi@xcarve:~ $
Try the longer url Bertus posted or you can download it using your windows or mac and copy the file to your Raspberry PI.
Screen Shot 2017-01-13 at 9.27.32 PM.jpg
Screen Shot 2017-01-13 at 9.27.32 PM.jpg (162.7 KiB) Viewed 2522 times

Bertus Kruger
Site Admin
Posts: 1649
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: installing UGS on PI3

Post by Bertus Kruger » Mon Jan 23, 2017 9:08 am

ozybard wrote:
erniehatt wrote:Bertus, not sure what you mean.
Could I suggest that you have a look at my forum post on "GRBL 1.1 Released page 2".

I encountered odd behaviour attempting to update to v1.1 as did T_D and although now resolved I still do not understand what happened to correct the problem.

I am however suspicious of the v1.1 upgrade process.

I have both bCNC and UGS working fine. Perhaps your problems are not hardware based but are displaying similar symptoms to those I described.

Hope this helps
Yes... I have included 3 new firmware upgrade scripts to help with the firmware updates for v0.9 , v1.1 and future releases.

All you have to do it run the script and it will automatically write the firmware to the CNC Hat.

The current Hat's are all shipped with V1.1

Bertus Kruger
Site Admin
Posts: 1649
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: installing UGS on PI3

Post by Bertus Kruger » Mon Jan 23, 2017 9:10 am

erniehatt wrote:Hi Bertus,
Yes read through that post, and a lot of things, are similar to what I am experiencing,, but nothing seems to change anything.
Yes unplugging the power can at times do wonders, I have used on many occasions to fix PC problems, didn't do much for the PI though.
As you may by now realise I have purchased another board, and hope it makes a difference, if not then I have a spare, but I hope it fixes things, then I have not wasted my Cash.
Is the new software available yet, I would like to use that when I connect it all together again.
It still puzzles me as to why it is working nicely one instance and not the next
New software is available...

Be sure to run the Raspberry Pi 3 serial setup script once if using a RPI3.

http://wiki.protoneer.co.nz/Raspberry_P ... Card_Image

Bertus Kruger
Site Admin
Posts: 1649
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: installing UGS on PI3

Post by Bertus Kruger » Mon Jan 23, 2017 9:11 am

rmasci wrote:That URL works for me off my Raspberry PI:

Code: Select all

pi@xcarve:~ $ wget http://bit.ly/1M6z2ys -O ugs.zip
converted 'http://bit.ly/1M6z2ys' (ISO-8859-1) -> 'http://bit.ly/1M6z2ys' (UTF-8)
--2017-01-13 21:21:09--  http://bit.ly/1M6z2ys
Resolving bit.ly (bit.ly)... 67.199.248.10, 67.199.248.11
Connecting to bit.ly (bit.ly)|67.199.248.10|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://github.com/winder/builds/raw/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip [following]
converted 'https://github.com/winder/builds/raw/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip' (ISO-8859-1) -> 'https://github.com/winder/builds/raw/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip' (UTF-8)
--2017-01-13 21:21:10--  https://github.com/winder/builds/raw/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip
Resolving github.com (github.com)... 192.30.253.113, 192.30.253.112
Connecting to github.com (github.com)|192.30.253.113|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://raw.githubusercontent.com/winder/builds/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip [following]
converted 'https://raw.githubusercontent.com/winder/builds/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip' (ISO-8859-1) -> 'https://raw.githubusercontent.com/winder/builds/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip' (UTF-8)
--2017-01-13 21:21:10--  https://raw.githubusercontent.com/winder/builds/master/UniversalGCodeSender/UniversalGcodeSender-v1.0.9.zip
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.128.133, 151.101.64.133, 151.101.0.133, ...
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.128.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10078481 (9.6M) [application/octet-stream]
Saving to: 'ugs.zip'

ugs.zip                                 100%[=================================================================================>]   9.61M  3.11MB/s   in 3.1s

2017-01-13 21:21:14 (3.11 MB/s) - 'ugs.zip' saved [10078481/10078481]

pi@xcarve:~ $
Try the longer url Bertus posted or you can download it using your windows or mac and copy the file to your Raspberry PI.
Screen Shot 2017-01-13 at 9.27.32 PM.jpg

Thanks. I have now included UGS in the standard image...

And LaserWeb3... :)

erniehatt
Posts: 292
Joined: Thu Nov 03, 2016 8:16 am

Re: installing UGS on PI3

Post by erniehatt » Mon Jan 23, 2017 9:04 pm

Thanks Bertus,
I will try it in the current board, but I still think it has a problem.

Whittler
Posts: 52
Joined: Mon Sep 26, 2016 2:26 pm

Re: installing UGS on PI3

Post by Whittler » Wed Jan 25, 2017 5:04 am

"All you have to do it run the script and it will automatically write the firmware to the CNC Hat.
The current Hat's are all shipped with V1.1"

It took four RP-3 reboots and 4 tries of tries of running the script before it would update the CNCHat. Really strange.
Research is the only place in a company where you can continually have failures and still keep your job.
I knew immediately that was where I belonged.

Bertus Kruger
Site Admin
Posts: 1649
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: installing UGS on PI3

Post by Bertus Kruger » Wed Jan 25, 2017 9:49 am

Whittler wrote:"All you have to do it run the script and it will automatically write the firmware to the CNC Hat.
The current Hat's are all shipped with V1.1"

It took four RP-3 reboots and 4 tries of tries of running the script before it would update the CNCHat. Really strange.
Very strange. I have found that running the firmware update script the first time might not do it. But the second time the upload and verify text shows.

I will add it to my todo list to get that sorted with the next release.

Whittler
Posts: 52
Joined: Mon Sep 26, 2016 2:26 pm

Re: installing UGS on PI3

Post by Whittler » Wed Jan 25, 2017 2:23 pm

Bertus Kruger wrote:
Whittler wrote:"All you have to do it run the script and it will automatically write the firmware to the CNC Hat.
The current Hat's are all shipped with V1.1"

It took four RP-3 reboots and 4 tries of tries of running the script before it would update the CNCHat. Really strange.
Very strange. I have found that running the firmware update script the first time might not do it. But the second time the upload and verify text shows.

I will add it to my todo list to get that sorted with the next release.
Each time I would run it it would just freeze the script. I made sure to run the Raspberry Pi 3 serial setup script first the second time I rebooted as I did not do it the first time. It still froze when I ran the update script. Repeated process on the third try with same outcome. The forth time it worked. I am guessing at the least the first time failure was from forgetting to run the serial script.
Research is the only place in a company where you can continually have failures and still keep your job.
I knew immediately that was where I belonged.

Bertus Kruger
Site Admin
Posts: 1649
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand
Contact:

Re: installing UGS on PI3

Post by Bertus Kruger » Thu Jan 26, 2017 9:02 am

Whittler wrote:
Bertus Kruger wrote:Each time I would run it it would just freeze the script. I made sure to run the Raspberry Pi 3 serial setup script first the second time I rebooted as I did not do it the first time. It still froze when I ran the update script. Repeated process on the third try with same outcome. The forth time it worked. I am guessing at the least the first time failure was from forgetting to run the serial script.
Interesting... I will investigate some more.

The RPI 3 config script reboots the RPI cause the hardware setup needs a reboot.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests