Using shield with Arduino Mega 2560

Post Reply
Posts: 1
Joined: Fri Nov 16, 2018 10:58 pm

Using shield with Arduino Mega 2560

Post by wandiligong » Fri Nov 16, 2018 11:33 pm

I have a project with 2 stepper motors. Using Protoneer shield V 3.0 and DRV8825 drivers with AcceStepper and Arduino UNO everything works well - motor control and limit stops. Will accelerate/dec, run multiple motors at same time, etc etc.
Note I am not using GRBL
Because sketch is getting to UNO limits and I want easy access to other Analog In pins I have tried to use Arduino Mega 2560 with no success
I have reverted to trying the AccelStepper simple constant speed sketch (from library examples) but no luck. This works OK with UNO but the sketch will not even load to Mega when shield is attached (times out). I have tried loading sketch to UNO without shield attached - loads fine but after then attaching shield motor does not respond?
I have tested Mega with other sketches (no shield) and it seems to be in good operating condition
AccelStepper literature says it is tested with Mega

I have read that pinouts are different UNO/Mega and about pin mapping, also seems to be different timers, but I don't know enough about these topics to see whether this is the problem

Has anyone had success with Mega/CNC Shield/DRV8825/AccelStepper?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest