Cannot get CNC.js to work

Question/Answers related to this version of the board.
Post Reply
Posts: 2
Joined: Sat Jun 25, 2016 7:31 pm

Cannot get CNC.js to work

Post by longshot » Sat Jun 25, 2016 7:44 pm

Is there something I'm missing. I'll be honest i'm not a Linux expert but I'm always willing to learn. I've read post after post after post and it seems everyone is able to remote into their Pi via the web except for me.

So i downloaded the latest image, formated and uploaded the image to the SD card via the disk imager program.
Fire up the PI and I'm in the desktop.
I run the little serial program and make sure i can connect to /dev/ttyAMA0 and the correct baud rate
I can open bCNC and connect . . . (motors are not connected, just wanted to make sure i could connect)
I go to run the CNC.js script and i'm greeted with "Started the server at http:\

Of course there's no way to connect to this. I am on Wifi (no bluetooth module). I am able to get on the internet with the pi and it says the pi is connected to

My guess is is the default and its just a place holder till the user changes it. What do i change it to? and How do i do it? I'm so lost . . .

First: CNC nor Sudo CNC nor ~/.npm/bin/cnc work in the terminal

I had to download $ npm install -g cncjs just to get father. . .

I've already tried cnc -H and all it tells me is this:
syscall: 'listen'

Desperate please help. I'm sure its something super simple i'm missing.

Bertus Kruger
Site Admin
Posts: 1670
Joined: Wed Feb 03, 2016 10:26 pm
Location: Wellington , New Zealand

Re: Cannot get CNC.js to work

Post by Bertus Kruger » Tue Jun 28, 2016 2:12 am


On the Pi if you open the browser and go to you should see CNC.js

To open it from another computer you will need to know the local Ip address of the Pi. (run ifconfig on the Pi's terminal to get the ip address back that will likely be 192.168.1.???)

Try the above and let me know if you have success or not...

Kind regards.

Posts: 2
Joined: Sat Jun 25, 2016 7:31 pm

Re: Cannot get CNC.js to work

Post by longshot » Thu Jul 07, 2016 3:13 am

Looks like its working, thanks for the advice!!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests