Search found 16 matches

by regpye
Tue Apr 06, 2021 4:04 am
Forum: Old CNC Shield V3.00 and Chines copies of it...
Topic: This problem, would it be hardware, software or firmware???
Replies: 5
Views: 451

Re: This problem, would it be hardware, software or firmware???

I have had no problems whatever running GRBL 1.1h and all others before that version.
Solved the problem as well, I reprogrammed GRBL to only use positive space.

I have changed the config.h file and removed the comments marks //
and now have #define HOMING_FORCE_SET_ORIGIN
by regpye
Sun Mar 21, 2021 9:23 pm
Forum: Old CNC Shield V3.00 and Chines copies of it...
Topic: This problem, would it be hardware, software or firmware???
Replies: 5
Views: 451

Re: This problem, would it be hardware, software or firmware???

Thanks Bertus, I already did that yesterday. I decided to test with Universal Gcode Sender and without any other changes the laser worked perfectly. That showed me that the machine was set up correctly. I then found in my old download folder an old copy of LaserGRBL from a few years ago, and install...
by regpye
Sun Mar 21, 2021 2:26 am
Forum: Old CNC Shield V3.00 and Chines copies of it...
Topic: This problem, would it be hardware, software or firmware???
Replies: 5
Views: 451

Re: This problem, would it be hardware, software or firmware???

I am not getting any replies, so I stripped down all the wiring and started again. :( This time I only wired the stepper motors and the limit switches. I turned off homing in the configuration to do the first test. The X and Y motors needed reversing, so instead of changing the configuration file, I...
by regpye
Fri Mar 19, 2021 9:32 am
Forum: Old CNC Shield V3.00 and Chines copies of it...
Topic: This problem, would it be hardware, software or firmware???
Replies: 5
Views: 451

This problem, would it be hardware, software or firmware???

I have a puzzling problem that I have not been able to work out, maybe someone here can advise me on what is going on and how to fix it? I have built another laser engraver/cutter, it is my fifth one, so I am not a noobie and have some experience. The machine uses Arduino UNO (genuine) and a Chinese...
by regpye
Fri Jan 01, 2021 4:59 am
Forum: Old CNC Shield V3.00 and Chines copies of it...
Topic: dissable Z limit?
Replies: 2
Views: 205

Re: dissable Z limit?

I made a discovery that I am using and may be helpful to others. I downloaded the latest version of LaserGRBL and within that program under tools, are able to flash a new GRBL onto your Arduino. Amongst the selections is a version of GRBL 1.1h (latest version) that has no Z, so after flashing mine I...
by regpye
Sun Dec 27, 2020 2:05 am
Forum: Old CNC Shield V3.00 and Chines copies of it...
Topic: Y-axis motors not running in sync
Replies: 2
Views: 349

Re: Y-axis motors not running in sync

Problem fixed. Found that the plug itto the motor driver had a bad connection. Luckily I didn't blow the driver. Refitted the connection and now it is working OK, the problem was that one motor wasn't working at all and the other motor was doing all the driving.
by regpye
Sun Dec 27, 2020 1:58 am
Forum: Old CNC Shield V3.00 and Chines copies of it...
Topic: Y-axis motors not running in sync
Replies: 2
Views: 349

Y-axis motors not running in sync

I am having a bit of a problem and can't work out how to fix it or what is causing it. I have built a laser and have a strange problem that has developed. The bed is wide 1500mm so i used two stepper motors, one at either side. i have cloned the A on the CNC shield to be the second Y motor. The move...
by regpye
Sun Dec 27, 2020 12:25 am
Forum: Old CNC Shield V3.00 and Chines copies of it...
Topic: dissable Z limit?
Replies: 2
Views: 205

dissable Z limit?

I have built a laser engraver for a friend and am setting it up now. I have run into a problem that I can't sort out and need some help please. The machine has only X and Y, no Z movement. I have put the laser control onto Z- limit pin on the CNC shield board and have put a LED on that pin for testi...
by regpye
Sun Dec 10, 2017 8:26 am
Forum: Old CNC Shield V3.00 and Chines copies of it...
Topic: Arduino Esplora
Replies: 0
Views: 2468

Arduino Esplora

Has anyone used an Arduino Esplora as a pendant to control GRBL?
I don't know if it is possible, but it looks interesting.
by regpye
Fri Dec 08, 2017 6:33 am
Forum: Old CNC Shield V3.00 and Chines copies of it...
Topic: Z axis motor problem.
Replies: 5
Views: 2671

Re: Z axis motor problem.

The only version .8 that I have been able to find is grbl_v0_8c_atmega328p_16mhz_9600.hex and when I try and use Xloader, it takes forever to send to the board. After sending I am not able to connect, so maybe there is a problem with this hex file?? Are there other 0.8 versions available somewhere f...