Search found 11 matches

by PropellerHat
Sun Nov 15, 2020 12:18 pm
Forum: Current Version(2.60)
Topic: Control buttons causing a ton of error messages
Replies: 1
Views: 37

Re: Control buttons causing a ton of error messages

Well I changed into using the gnd pin right next to the control pins (I used other ground earlier) and it looks like this solved the issue.

So the ground pins on the board are not all directly connected to each other or what..?

Anyway happy to have the buttons working correctly :)
by PropellerHat
Sat Nov 14, 2020 4:33 pm
Forum: Current Version(2.60)
Topic: Control buttons causing a ton of error messages
Replies: 1
Views: 37

Control buttons causing a ton of error messages

Hi I am trying to connect the hold, resume, abort and reset pins to physical buttons but apparently noise (???) is causing a lot of problems. I thought it was the spindle U V W cables within the same sheath that caused the issue and I made a new cable to be put in between the VFD and the spindle (an...
by PropellerHat
Mon Nov 02, 2020 1:56 pm
Forum: Current Version(2.60)
Topic: GPIO pins used
Replies: 8
Views: 1300

Re: GPIO pins used

How about the other GPIOs on the RPI, could they be used for controlling other stuff like relays as moving the HAT further from the connector would allow access to the rest of the pins..?
by PropellerHat
Thu Oct 01, 2020 1:42 pm
Forum: Current Version(2.60)
Topic: Getting dual axis self square gantry working
Replies: 24
Views: 2494

Re: Getting dual axis self square gantry working

Hi again Ok... I got the GRBL flashed (IDE says "Done uploading") BUT only when the #define ENABLE_DUAL_AXIS is commented out. If I take away the "// " from that line, it won't compile. Whaaaat the.....?? Renaming the version worked ( $I tells me "ver:1.1x.20190825:" ) But What am I missing in the c...
by PropellerHat
Tue Sep 29, 2020 4:45 pm
Forum: Current Version(2.60)
Topic: Getting dual axis self square gantry working
Replies: 24
Views: 2494

Re: Getting dual axis self square gantry working

I tried this but for some reason my Arduino IDE wasn't able to compile since last weekend. I tried to uninstall it in many ways to make room for a fresh installation but jesus this linux stuff... So I ended up starting from zero with everything - fresh Protoneer's image (V510) on the SD. Now it's up...
by PropellerHat
Sun Sep 27, 2020 10:30 am
Forum: Current Version(2.60)
Topic: Getting dual axis self square gantry working
Replies: 24
Views: 2494

Re: Getting dual axis self square gantry working

Hi The version was 1.1h already before flashing again, so I can't say if it actually went right. I am not very experienced in using Arduino IDE but it said "Upload complete" or something similar after everything LOOKED like it went as supposed. Guess I'll try to upload it again some day, starting fr...
by PropellerHat
Fri Sep 25, 2020 1:06 pm
Forum: Current Version(2.60)
Topic: Getting dual axis self square gantry working
Replies: 24
Views: 2494

Re: Getting dual axis self square gantry working

Hi again. Finally I have gotten the machine in the state of getting this self squaring to work but no, I can not manage. If I have the Y clone bridging applied, the machine homes otherwise perfectly but there is no squaring what so ever. If I remove the Y cloning bridges and replave them with A3 A4 ...
by PropellerHat
Thu Sep 17, 2020 5:33 pm
Forum: Current Version(2.60)
Topic: NC limit switch doesn't clear after the first hit
Replies: 3
Views: 134

NC limit switch doesn't clear after the first hit

Hi yall! I have tried for hours to solve this nut scratcher: When homing Z does fine. X gets alarm 8 (failure to clear the endstop) after the first, faster search. I have them set normally closed, and $5=1. Otherwise Z and X switches are supposed to be similar, but the homing direction is inverted f...
by PropellerHat
Fri Sep 04, 2020 1:11 pm
Forum: Current Version(2.60)
Topic: Getting dual axis self square gantry working
Replies: 24
Views: 2494

Re: Getting dual axis self square gantry working

The most valued info right here, thanks! Going to try this on 2 machines this weekend. Just one question: The bridging of the clone drive thingies... the way it is done in the second pic of the theme in https://wiki.protoneer.co.nz/Raspberry_Pi_CNC right? (4th socket cloning Y axis) There are a coup...
by PropellerHat
Tue Jun 30, 2020 12:57 pm
Forum: Current Version(2.60)
Topic: Homing with 2 motors on Y axis
Replies: 11
Views: 1663

Re: Homing with 2 motors on Y axis

I am working on a cnc with 2 Y motors as well.

How about this topic? Any solutions?

Pretty important feature IMO... Isn't it pretty much the most common setup, 2 motors on Y or X..?